Get in touch
Back
Resolved

hello world was down

Started 31 May at 06:54pm HDT.

Created

Even if the whole world is down, you have to get up again and say "Hello!".

Posted 31 May at 06:54pm HDT.